Archive

Posts Tagged ‘phpmyadmin’

Ubuntu Software 之 phpMyAdmin安装时的几个小问题

2010/05/18 留下评论

1. “无法加载mcrypt 扩展,请检查您的PHP 配置。” / “Cannot load mcrypt extension. Please check your PHP configuration.”
键入

sudo apt-get install php5-mcrypt

done.

2. “链接表的额外特性尚未激活。要查出原因,请点击此处。” / “The additional features for working with linked tables have been deactivated. To find out why click here.”
导入 phpMyAdmin/scripts/create_tables.sql文件,创建名叫phpMyAmin的数据库;
然后复制phpMyAdmin/config.sample.inc.php为config.inc.php,编辑:

/* Advanced phpMyAdmin features */
// $cfg[‘Servers’][$i][‘pmadb’] = ‘phpmyadmin’;
// $cfg[‘Servers’][$i][‘bookmarktable’] = ‘pma_bookmark’;
// $cfg[‘Servers’][$i][‘relation’] = ‘pma_relation’;
// $cfg[‘Servers’][$i][‘table_info’] = ‘pma_table_info’;
// $cfg[‘Servers’][$i][‘table_coords’] = ‘pma_table_coords’;
// $cfg[‘Servers’][$i][‘pdf_pages’] = ‘pma_pdf_pages’;
// $cfg[‘Servers’][$i][‘column_info’] = ‘pma_column_info’;
// $cfg[‘Servers’][$i][‘history’] = ‘pma_history’;
// $cfg[‘Servers’][$i][‘tracking’] = ‘pma_tracking’;
// $cfg[‘Servers’][$i][‘designer_coords’] = ‘pma_designer_coords’;

去掉注释,done.

3. “配置文件现在需要一个短语密码。” / “The configuration file now needs a secret passphrase (blowfish_secret).”
编辑phpMyAdmin/config.inc.php文件,在:

/* Authentication type */
$cfg[‘Servers’][$i][‘auth_type’] = ‘cookie’;

下添加一行:

$cfg[‘blowfish_secret’] = ‘szoo’; //’szoo’为自定义字符串

done.

分类:Ubuntu 标签:, ,